Houdini 12.1 リファレンス ウィンドウ

General User Interface

Draw Lines Smoothly

HoudiniのUIと3Dビューポートを含むベクトルすべてをアンチエイリアスするOpenGLオプションを有効にします。これは、ノードタイル間を接続しているワイヤーで直ぐに違いを確認することができます。

また、Display OptionsウィンドウのEffectsタブのSceneセクションにあるSmooth Linesオプションも参照してください。

Color Pane Headers with Network Contexts

ペインのヘッダー部はペインタブとパスガジェットで構成されていて、デフォルトでは背景が灰色です。このオプションをオンにすると、ペインのヘッダーの色は典型的なネットワークタイプカラーになります。

Show Images for Image Files in File Browsers

画像選択用のファイルダイアログのデフォルト設定にShow Imagesを有効にします。(オフの場合は、ファイルダイアログでRMBクリックのメニューから有効にします)

Play Audio with Popup Notifications for

メッセージ、警告、エラーのダイアログウィンドウが開いた時に音を鳴らします。

File Choosers

ファイル選択ダイアログの形式を選択します。

注目

このオプションはMacだけ利用可能です。

Houdini Chooser Only

Houdiniは、すべてのファイルブラウザーで独自の選択ダイアログを使用します。

Mix of Houdini and Native Choosers

HoudiniはFile > OpenではOSのネイティブのファイル選択ダイアログを使用し、それ以外は独自の選択ダイアログを使用します。

Native Chooser Only

Houdiniは、すべてのファイルブラウザーでOSのネイティブのファイル選択ダイアログを使用します。

Startup in Desktop

Houdini起動時に表示するデスクトップを指定します。デフォルトはBuildです。

Global UI Size

UIのサイズを変更します。このパラメータを変更すると次のHoudiniセッションで反映されます。

Network Editor, Nodes, and Trees

Center Zoom on Mouse

ネットワークエディターでマウスカーソルを中心にズームします。

Connect Tiles with Thick Lines

ノード間の接続ラインを太くします。

Connect Tiles with Selectable Links

ノード間の接続ラインをクリックして新しいノードに再接続できます。このオプションはデフォルトでオンになっています。

注目

このチェックボックスをオフにすると、ノードをワイヤー上にドラッグアンドドロップすることができなくなります。

Move Tiles With Their Children

このチェックボックスがオンなら、ノードをドラッグすると、その子も一緒に移動します。しかし、Ctrlを押しながらドラッグすれば、そのノードだけが移動します。⇧ Shiftを押しながらドラッグすれば、その親も移動します。

このチェックボックスがオフなら、ノードをドラッグすると、そのノードだけが移動します。しかし、Ctrlを押しながらドラッグすれば、その子も移動します。⇧ Shiftを押しながらドラッグすれば、その親も移動します。

Enable Drop-on-Wire

ネットワークエディターでノードをワイヤー上にドラッグアンドドロップすると2つのノード間にノードが接続されます。

Place New tiles immediately

新しいノードの位置を指定するためにクリックしないで、ノードを選択すると直ぐにタイルを配置します。

Scroll to the New Tileオプションを有効にすると、新しく配置したタイルをネットワークビューの中心に表示するようにパンします。

Scroll to New Tile

新しく配置したタイルをネットワークビューの中心に表示するようにパンします。

Automatically pan when holding down Alt and dragging outside the network editor

このオプションがオンなら、ノードをネットワークエディターの外側にドラッグする時にAltを押したままにするとネットワークエディターをパンすることができます。これはノードを現在のネットワークエディターから見えない場所に置きたいときに役に立ちます。

Scale Operator Names

ズームイン・アウトする時にネットワークエディターのノード名をスケールします。

Minimum Op Name Size

ズームするときのノード名の最小サイズを設定します。これは名前が小さくなりすぎて判読不能になることを防止します。

Op Name Size

スケールしない時のノード名のサイズ。これを全体のスケールとして使用し、優先作業ズームレベルでのノード名の読みやすさに影響があります。

Maximum Op Name Size

ズームするときのノード名の最大サイズを設定します。デフォルトのフォントでは値を45より大きくすると失敗します。

Highlight the Currently Cooking Node

このオプションをオンにすると、処理中のタイルがクッキング時に点灯します。

Include Performance Statistics in Node Info

タイルのポップアップ情報にパフォーマンスを含めます。

Change SOP Render and Display Flags Separately

このオプションがオンの場合、SOPのレンダー・ディスプレイフラグをクリックすると、レンダーとディスプレイのフラグを別々に設定することができます。オフの場合、レンダー・ディスプレイフラグをクリックすると、一緒のフラグになります。

Display Icons in Operator Tree Views by Default

ツリービューにノードのタイルを表示します。

3D Viewports

Scene Renderer
H11

Houdini 11とそれ以前のバージョンで出荷していたシーンレンダラーですが、推奨しません。これは将来削除されます。

OpenGL 1.2

基本レンダラーで、古いOpenGLの安定した機能のパイプラインをサポートしていますが、GLSLシェーダーには対応していません。

OpenGL 2.1

基本シェーダーベースレンダラーで、GL2.1ハードウェアとOSXをサポートしています。

OpenGL 3.2

最新のシェーダーベースレンダラーでOpenGL3と4のハードウェアと、さらに選択ハイライトとジオメトリシェーダーのような機能をサポートしています。これがお勧めの設定です。

役立つ情報

通常は、あなたのマシンで利用可能な一番高いバージョンのGLを使用するべきです。GLレンダラーは、それに必要なGLバージョンをドライバーがサポートしていなければ、削除されます。バージョンを ダウングレードする必要がある時は、その高いGLバージョンで何か問題が遭遇した時だけです。

OpenGL 3.2レンダラーは描画処理の大部分をグラフィックハードウェアに依存するように設計しています。その結果、ローエンドの古いOpenGL 3ハードウェアでは、パフォーマンスが非常に遅くなる場合があります。そのようなハードウェアでは代わりにOpenGL 2.1レンダラーを使ってください。

Orientation
Y Up

プラスのY軸が上方向を指すHoudiniの標準の方向です。

Z Up

プラスのZ軸が上方向を指す右手座標系の方向です。

Tumbling Method
Standard Houdini Tumbling

標準のHoudiniのディスプレイのタンブルのメソッド(LMBを使用)です。これはタンブルがマウスに接続されているかのように回転し、スクリーン上の同じ位置に戻すと、以前の位置と同じ状態に戻ります。これは、ほとんどのユーザーで直感的に操作できます。

Classic Houdini Tumbling

典型的なタンブルのメソッドで、回したい方向と逆方向に小さい円を描くようにマウスを動かします。そうすればマウスで動かしている方向とは逆に連続して移動するタンブルの方向がわかるでしょう。これは、一度コツを覚えてしまえばタンブルでより多くの制御が実際には可能です。

80’s Style Euler Tumbling

80’s Style Eulerタンブルのメソッドです。これはほとんどの人に好まれています。

Panning Method
Move Pivot when Panning

Viewportの回転基準となるピボットは常にViewportの中心になります。これは、ジオメトリを外側にパンしても変わりません。

Maintain Viewport Pivot when Panning

ビューポートの回転基準となるピボットは該当するジオメトリ周りに維持されます。これはジオメトリをビューポートの中心から遠ざけた時でさえも維持されます。

Default Homing

Homeホットキーを入力したときの動作を設定します。デフォルトはObliqueでは、これは45度の値を持ちます。

Wire Toggle Mode

シェーディングモードを変更することができます。ビューポートでWホットキーを押すと、この設定と同じシェーディングモードになります。

Delay Inactive Viewport Redraws

このオプションをオンにすると、Houdiniは4面ビューで非アクティブなビューポートの再描画を遅らせます。4面ビューでは1つのビューがアクティブで、それ以外は非アクティブです。アクティブビューポートでアクションを実行すると、積極的に更新が行なわれ、非アクティブビューポートはそれに遅れて更新されます。アクティブビューポートを完全に更新した後に、非アクティブビューポートが再描画されます。このオプションをオンにするとパフォーマンスが改善されます。

Shelf Tools and Tabメニュー

Tool History Length

Tabメニューで使用したアイテムの履歴を保持する数

Tab Menu Operator Namespace Filtering

Tabメニューに表示する同じオペレータのバリアントを指定します。オペレータのバリアントは同じ基本オペレータ名を共有しますが、スコープ、ネームスペース、バージョンが異なります。

Show All Operators

利用可能なオペレータのバリアントすべてを表示します。

Show Only Operators with Preferred Versions

いくつかのオペレータのバリアント(指定したオペレータに定義した各ネームスペース毎に1つ)を表示します。各ネームスペースに対して、オペレータバリアントは優先バージョン(通常は一番高い番号)を表示します。

Show Single Operator from the Preferred Namespace

オペレータの1つのバリアントのみを表示します。表示されるバリアントは、最優先のネームスペースのバリアントです。この優先度はHOUDINI_OPNAMESPACE_HIERARCHY環境変数で設定することができます。同じネームスペースでバリアント候補がいくつかあれば、優先バージョンが使われます。

Takes

Allow Auto Take Mode for Locked Assets

自動テイクモードでロックしたアセットの内容を編集して、現行テイク内の内部パラメータを上書きすることができます。

注目

このパラメータは自動テイクモードに影響があり、通常モードではテイクしません。

Animation

Auto-Key: Add Keyframes on Parameter Change

チェックがオンの場合、パラメータを変更すると直ぐにキーフレームに反映されます。

Auto-Commit: Save Parameter Change at Keyframes

キーフレーム上のパラメータを変更すると、新しい値が自動的にそのキーフレームの値になります。そのため明示的に値をキーする必要がありません。

Set Additional First Key at Frame

最初に(キーフレームが未設定の状態)キーフレームを追加する時、指定したフレーム(通常はフレーム1)にもキーフレームが追加されます。空っぽのままにすると、キーフレームが余分に追加されません。

'1'に設定すると、Houdiniの古いバージョン(H6以前)の挙動に近づけます。これは自動的に最初のフレームにキーを追加します。

Global Set Key
Set Keys on Pending Channels

変更のあったチャンネルにキーを設定します。

Set Keys on All Scoped Channels

スコープしたチャンネルすべてにキーを設定します。

Default / Rotation Function

ここで指定したタイプ(例:cubic)が最初のセグメントのデフォルト補間になります。また回転で使うデフォルトの関数も設定することができます。

Auto Function

追加したキーフレーム間で最良の関数を自動的に決めようと試みます。無効の場合、キーフレームを追加すると、ここで指定したタイプのセグメントを挿入します。

Auto Slope

チャンネルの入力側・出力側の傾斜を自動的に合わせようと試みます。無効の場合、キーフレームを追加すると、新規セグメントの傾斜が指定した値に設定されます。

Hold Last Key

チャンネルの最後のセグメントにキーフレームを追加すると、最後のセグメントが最後のキーフレームとアニメーションの終わりの間が同じ値になるように修正されます。このパラメータを有効にすると、最後のセグメントの補間を変更することなくキーフレームを繰り返して挿入することができます。

Enable Channel Cache

このチェックボックスをオンにすると、チャンネルの評価がキャッシュ化されてチャンネルエディターの表示パフォーマンスを改善します。しかし、これによってチャンネルが変わった時にチャンネルエディターが適切に更新されなくなります。

Scope Parameters With Autoscope Enabled

autoscopeとしてマークした選択ノードのパラメータをチャンネルエディターに表示します。

Open Channel Editor if Closed

有効にすると、現在チャンネルエディターが表示されていない場合に、新しいチャンネルエディターウィンドウがポップアップで表示されます。

View Overridden Parameters in Motion View

CHOPで現在上書きされている選択ノードのパラメータをMotion Viewペインに表示します。

Rendering

Available Render Nodes

Houdiniで利用可能なレンダーノードがリスト表示されます。ここで利用するレンダーノードの有効・無効の設定をします。HOUDINI_DEFAULT_RENDERERS環境変数での優先度を上書きすることが可能です。上書きしたレンダーノードはプリファレンスではグレー表示になります。このリストで有効になっていないレンダーノードがシーン内に存在するとEnabled Byの項目で一時的に有効な状態であることが記されます。その仕組によって有効になったレンダーノードは、セッションからセッションに切り替わってもプリファレンスには影響を与えません。

Make All Render Nodes Available in Tool Palette and Tab Menu

有効にすると、すべてのレンダーノードが出力ドライバーツールパレットとタブメニューに表示されます。無効にすると、Available Render Nodesで選択したレンダーノードのサブセットのみが表示されます。

Handles

Hide Locked Handle Parts

ロックしたハンドルパーツを表示しないようにします。既存のハンドルに影響を与えるにはファイルを再読み込みする必要があります。

Color Transform Handles By Axis

このオプションをオンにすると、3Dビューアのトランスフォームハンドルの各軸が別々の色で表示されます。

Keep handle alignment when reselecting

このオプションをオンにすると、3Dビューアのトランスフォームハンドルが、別のオブジェクトを選択した時に同じ方向を保持します。

Default Handle Alignment

3Dビューアのトランスフォームハンドルの初期方向を決めます。

Object

ローカル空間に揃えます。

World

ワールド空間に揃えます。

View

ビューに揃えます。

Parent Object

オブジェクトの1番目の入力に揃えます。

Allow interior picking of Rotate Handles

このオプションをオンにすると、3Dビューアの回転ハンドルの内側をドラッグできるようになります。

回転ハンドルの内側をドラッグすると3軸を同時に回転することができます。

Default Transform Handles to Gimbal Mode

このオプションをオンにすると、3Dビューアでの回転ハンドルの初期モードがジンバルモードになります。ジンバルモードでは、回転サークルハンドルは常に整列した状態なので、それらのハンドルを操作すると、個々の軸の回転角度だけに影響を与えることができます。

Default 2D Orientation Handle Transform is Global

この設定はライトとカメラの操作で使用する方向ハンドルに影響があります。ハンドルの操作には、ローカル空間またはグローバル空間の2通りがあります。

この設定をオンにすると、デフォルトモードがグローバル空間になります。ローカル空間で操作するには、ハンドル操作時にShiftキーを押したままにします。この設定をオフにすると、デフォルトモードがローカル空間になり、グローバル空間で操作するにはShiftキーを押す必要があります。

Open Channel Editor If Closed When Scoping From Handles

ハンドルからスコープする時、新しいチャンネルエディター (まだ開かれていない場合)が開きます。

Scope Channels When Setting Keyframes
Do not Scope

表示するものを変更しません。

Add to Scope

どのチャンネルが既に表示されていようとも、さらにチャンネルをスコープに追加します。

Replace Scope

キーフレームをハンドルに追加する時にスコープしたどのチャンネルも置換します。

Objects and Geometry

Preferences

Highlight Object Selections in Viewport

ビューポートでオブジェクトを選択した時の視覚的な反応を設定します。

Automatic Parameter Folder Flipping when Picked in Viewer

参照が存在すれば、選択したオブジェクトの任意のチャンネルで参照される最初のパラメータを含むフォルダにパラメータペインフォルダを飛ばします。

Default Geometry Display

3Dビューアのデフォルトのジオメトリディスプレイモードを指定します。これはジオメトリ選択モードでの3Dビューアにのみ影響があります。

Show Current Operator

ジオメトリが現行(最後に選択した)ノードから表示・選択されます。

Show Display Operator

ジオメトリがディスプレイフラグが有効なノードから表示・選択されます。

Default Context Creation

デフォルトのコンテキスト作成モードを指定します。3Dビューアで、そのモードを変更するには、右上コーナーにあるアイコンを使います。

Create at Object Level

シェルフから新しくジオメトリ(例:Boxツール)を作成すると、そのジオメトリを含んだオブジェクトを新しく作成します。

Create in Context

ジオメトリが現行コンテキスト内に作成されます(例:同じオブジェクト内にジオメトリがもう1つ作成される)。

Use Existing Selection to Complete Actions

有効にすると、ツールを呼び出した時にアクションが実行できるなら既存選択を使います。

Secure Selection On by Default

デフォルトで安全な選択を有効にします。有効にすると、間違えてクリックしても選択が解除されないようになります。

Select Entire Subnets On by Default

有効にすると、デフォルトの挙動がコンテナノードを選択するときにサブネットを選択するようになります。

Highlight Selected Geometry in Viewport

オブジェクトを選択すると、Houdiniはビューポートでそれに該当するオブジェクトをハイライトします。

Popup Menu Selection

このオプションがオンの場合、複数オブジェクトを選択している状態で3Dビューア内で位置をクリックするとメニューがポップアップ表示されるので、そこからどれを選択するのか指定することができます。

Keep Position when Parenting
Never

Neverに設定すると、オブジェクトを子にした時に、オブジェクトの位置は、ワールド座標を維持せず、親のオブジェクトからの相対的な位置に配置されます。

Always

Alwaysに設定すると、オブジェクトを子にしても、オブジェクトの位置は、ワールド座標の位置と方向を維持します(これは、オブジェクトのTransform/Rotate/Scaleパラメータを修正して行なっています)。

Use Object Flag

この設定では、個々のオブジェクトのKeep Position When Parentingパラメータに応じてオブジェクトのワールド座標を維持します。

Kinematic Override
None

Noneの場合、キネマティックの上書きはありません。

Rest

Restの場合、すべてのボーンは停止位置でクッキングされます。ボーン停止位置はInverse Kinematicsの解決方法を制御します。

Capture

Captureの場合、すべてのボーンはキャプチャー位置でクッキングされます。ボーンキャプチャーはCapture and Capture Proximity SOPによってスキンジオメトリをキャプチャする時に使われます。

Keep Position When Moving

このオプションがオンの場合、オブジェクトを移動しても、子のオブジェクトの位置と向きには何も影響を受けません。これは、子のオブジェクトのpre-transformsまたはtransformパラメータを修正して行なっています。

Read-Only Pre-Transforms

このオプションがオンの場合、オブジェクトのpre-transformsを操作することができなくなります。

SOP Caching

Cull Level

値を大きくするほど、Houdiniはキャッシュサイズを抑えようとし、速度を犠牲にしてメモリを節約するようにします。

Memory Limit

ジオメトリ変換をキャッシュ化するのに使用するメモリ量

Unloading
Never

決してSOPをアンロードしません。

Flag

アンロードフラグが設定されているSOPのみをアンロードします。

Always

常にSOPをアンロードします。

Memory
Never

Memory Limitを無視します。

Always

Memory Limitに到達した時にSOPをアンロードします。

OBJ Caching

Houdiniは、オブジェクトのCache dataオプションを有効にした時にすでに計算済みの個々のオブジェクトに対してオブジェクト変換をキャッシュ化することができます。これは特にワールド空間座標の計算が重いようなオブジェクト(例えば、Stickyオブジェクト)、長い親子チェーンの最後のオブジェクト(例えば、Bone)で役に立ちます。このオプションはStickyとBoneオブジェクトではデフォルトでオンになっています。

Memory Limit

オブジェクト変換をキャッシュ化するのに使用するメモリ量

Enforce Limit

HoudiniがMemory Limitに従うが否か制御します。

Clear Cache

直ぐにキャッシュを空にします。

役立つ情報

個々にCache dataオプションを設定しないで、オブジェクト全てに対してキャッシュ化をオフにするには、Memory Limitを0に設定して、Clear Cacheをクリックします。

役立つ情報

objcacheコマンドをHScriptで使うことでOBJキャッシュを管理することができます。

Particles

Skip Particle Info Generation (Faster)

POPタイルの情報ポップアップ(タイル上でMMBクリック)の生成を止めます。これによって、より多くの情報を取得できなくなりますが、パーティクルシミュレーションを高速化することができます。

Motion and Audio

Maximum Time Slice Size (Frames)

このオプションでは、フレーム単位によるTime Sliceのサイズを制限することができます。デフォルトの最大は60フレームです。これは履歴の数フレームだけを必要とする場合に役に立ち、そして、プレイバーは大きな間隔で前にジャンプします。Time Sliceが、この最大サイズより大きい場合、現行フレームから後へクリップされます(このスライスと前のスライスにギャップが生じるので)。スライスは常に現行フレームで終わります。

Enable Time Slice Flag when Creating CHOP

CHOPをレイアウトエリアに配置する時のデフォルトの挙動を設定します。

このオプションがオンの時に作成されたTime Slice機能付きのCHOPすべては、デフォルトでTime Sliceフラグが有効になります。オフの時は、Time Sliceフラグは無効になります。大きなTime Sliceのネットワークを作成して処理するときは、このオプションをオンのままにするのが良いです。このオプションはデフォルトではオフになっています。

Minimal Time Slice Cooks

Time SliceのCHOPのいくつかは、フレーム毎のクッキングとは違い、クッキングを最小にすることができます。クッキングが不要な時、または同じ出力を生成する時は、これらのCHOPは入力が変わるまでクッキングを停止します。

この機能を持つCHOPは以下の通り:

  • Copy chop

  • Count chop

  • Envelope chop

  • Lag chop

  • Spring chop

  • Trigger chop

最小クッキングは、これらのTime SliceのCHOPが一定ではないCHOPの入力や時間依存のCHOPの入力を持っていれば、適用されません。このオプションはデフォルトではオフです。これは操作性と独立した入力またはイベントに反応するCHOPネットワークを高速化することができます。

Compositing

Cache

Interactive Cache Size

タイルキャッシュのサイズをMBで設定します。コンポジターを常に使用するのであれば、この値を非常に大きな値に設定するべきです(256MB以上でシステムで利用可能なメモリの半分)。これはインタラクティブアプリケーションにのみ適用されます。

Non-interactive Cache Size

タイルキャッシュのサイズをMBで設定します。これはコンポジターをインタラクティブに使わない時(hbatch, hython)に使います。

Reduce Cache Size when Idle

Houdiniのようなインタラクティブアプリケーションでは、コンポジターが短い時間(5分)でアイドル状態になると、キャッシュをこのサイズにまでゆっくりと下げます。これによって他のアプリケーションで使用できるメモリを解放することができます。

Clear Cache

コンポジットキャッシュすべてをクリアにします。

Cooking

Multi-threaded Cooking

オンにすると、マルチスレッド処理が有効になります。オフにすると画像の処理(メインのHoudiniプロセス)は1個のスレッドだけで使われます。

Threads

クッキングで使うスレッドの数を指定します。1に設定すると、メインのHoudiniスレッドのみが画像を処理します(Multi-threaded Cookingをオフにするのと同様)。マルチプロセッサーコンピュータをフルに使用するには、プロセッサーの2倍の数でたくさんの処理スレッドを使ってください。

Use GPU to Assist Compositing

あるCOPではOpenGLを使ってアクセラレーションすることができます。このプリファレンスの変更を反映するには、Houdiniを再起動する必要があります。以下のCOPがアクセラレーションの利用が可能です。*のマークが付いたCOPはアクセラレーションの効果が大きいです。

  • 2D transforms, including motion blur*

  • Fog (noisy fog*)

  • Z-composite

  • Lighting (all, volumetric*)

  • Environment map

  • 基本カラー補正すべて(bright, gamma, color curve, HSV, hue curve*, color correctなど)

  • Expand*

  • Convolve*

  • Deform*

  • Corner Pin & Unpin

  • Noise (perlin, imp. perlin, sparse*, alligator*; no random)

Use Collapsible Pixel Operators

オンにすると、直列の折り畳み可能なピクセルオペレータ(青いCOPs)を1つのオペレーションに結合されます。オフにすると、それらのオペレータはすべて個々に処理されます。

Tile Size

タイルのサイズ。画像がこれらのタイルに分割されて、まとめて処理されます。常に特定の解像度で作業していれば、水平・垂直の解像度を正確に分割するタイルサイズを指定したい場合があります。この値を変更すると、すべてのキャッシュをクリアします。タイルの中は最低でも1024ピクセル必要です。

Resolution Limit

コンポジターの最大解像度を指定することができます。

Interactive

Cook Displayed Operators on Startup or Load

このオプションをオンにすると、hipファイルをロードした時に、まず最初に表示するCOPを処理します。このオプションをオフにすると、それらのCOPは処理されないでビューポートがブラックのままになります。

Use Fast Interactive Cooking

オンにすると、画像の解像度はインタラクティブに編集している間(ハンドルのドラッグ、スライダーやXCFスライダーのスライディング)は自動的に低解像度にスケールダウンします。これによって品質を犠牲にして、より高速な反応が得られます。オフにすると、画像は標準の解像度で処理されます。

Only Use Fast Cooking On Slow Operations

オンにすると、高速オペレーション(例えば、Bright, Gamma,Timing COP)はインタラクティブに画像をスケールダウンしません。オフにすると、すべてのオペレーションがユーザー操作中に画像をスケールダウンします。

Use Fast Cooking on Images Larger Than

ユーザー操作中にダウンスケールする画像の低解像度の限度を設定します。この制限よりも画像が小さくなるとダウンスケールしなくなります。画像が、このプリファレンスのアスペクト比に一致しない場合、画像のピクセル数が比較されて、限度として使われます。

Interactive Rendering Fraction

ダウンスケール係数を指定します。係数を小さくするほど画像品質を犠牲にしてユーザー操作中の更新がより速くなります。

Cooking Feedback

1枚の画像の処理中に受け取るフィードバックのタイプを設定します:

None

画像の処理が終わるまで何も更新しません。

Progress Bar

画像ビューアの上部にあるプログレスバーが画像処理中に定期的に更新します。

Image Update

処理中の画像を含んだビューポートを定期的に更新し、実際の処理状況を表示します。これはわずかにパフォーマンスの影響があります。

Selectors

Never Prompt for Optional Inputs

オンの場合、最低限の数のソースが接続されると、入力選択が完了したものと見なされます。Always Placeオプションを指定すれば、COPはすぐに選択したビューポートに配置されます。

Never Prompt for a Generator’s Input(s)

オンの場合、ジェネレータの入力が決してプロンプトされません。

Always Place the New COP in the Current Viewport

オンの場合、すべての入力の選択が完了すると、COPが目的のビューポートをプロンプトしないで現行ビューに配置されます。

Always Place New Generators in a New Viewport

オンの場合、ジェネレータは利用可能であれば(そうでなければ現行ビューポートが使われます)、新しいビューポートに追加されます。オフの場合、目的のビューポートがプロンプトされます。

Names

このページでは共通の平面タイプの名前をカスタマイズすることができます。デフォルトの名前は英語の平面の名前の頭文字で、大文字です。これらの名前はスコープフィールドや平面リスト、VEXスクリプト、Houdini .picファイルの出力で使用される名前です。

Colors

COPはファミリータイプで色付けすることができます。そのファミリー内の新規COPは、そのタイルをファミリーカラーに色付けして、識別しやすくなります。

Enable COP Auto Coloring

すべてのCOPタイプに対して、この機能を有効・無効にします。あなたにとって重要でないファミリータイプは個々に無効にすることもできます。

Generators

すべてのジェネレータに対する色。ジェネレータは入力を受け取り、平面を'インライン'(ネットワークの途中で)で生成することができるので、これは作成またはマスクされるネットワーク平面内の場所を特定するのに役に立ちます。

Pixel Functions

すべての折り畳み可能なピクセルオペレーションに対する色。折りたたみ可能なピクセルオペレーションはチェーンをグループにしたときのみ機能するので、これらのタイプのオペレーションを最適化するのに役に立ちます。

Timing

すべての時間関係のオペレーションと画像に関係しないオペレーション(例えばMergeやDelete)に対する色。これらのオペレーションは通常は画像をクッキングせず、またはキャッシュメモリを使用しません。これは大きなネットワーク内で時間の変化を突きとめるのに役に立ちます。

VEX

すべてのVEXベースのオペレーションに対する色。VEX COPは、VEXスクリプトのパラメータ名に一致するすべての平面の名前がピクセル単位基準で、それらのパラメータを上書きする特性を持ちます。つまり、これらのCOPを認識することが重要です。

Cineon

このページでは、すべての新規File COPとCompositor出力ドライバーのCineonパラメータすべてのデフォルト値を定義します。また、Cineonファイルをロードまたはこれらの2つのコンテキスト外(例えば、Save Image...COPタイルメニューから)に保存する時に使われるCineonパラメータも定義します。Cineonファイルの拡張子は、.cinです。

Convert from 10 bit Log

オンの場合、Cineonファイルが線形空間に変換されます。オフの場合、Cineonファイルは10ビットの対数空間(0 - 1024の範囲の値)のままになります。

LUT File

10ビットCineon変換を含むLookUp Tableファイル(.lut)。このファイルは手動またはスタンドアローンのCineonやilutツールを使って作成します。

Black Point

線形カラー空間に変換される時にブラックにマッピングするCineonの値(0-1023)。これとWhite PointFilm GammaがCineonファイル(.cin)をロードした時に使われます。これはLUT Fileフィールドが指定されていない時にのみ影響があります。指定されていれば、変換にはLUTが使われます。

White Point

Cineonのホワイトポイントで、90%の画像の明度を意味するCineon値(0-1023)を定義します。このパラメータはLUTが指定されていれば使われません。

Film Gamma

Cineonフィルムガンマで、Cineon空間を線形画像空間(コンポジターが操作する空間)に変換するときに使用するガンマを定義します。このパラメータはLUTが指定されていれば使われません。

Scripting

Expression Language
hscript

新規ノードのデフォルトエクスプレッションをhscriptに変更します。

python

新規ノードのデフォルトエクスプレッションをpythonに変更します。

Parameter Fields

パラメータエディターに配置されているようなパラメータの入力ボックス。

Text Editors

Edit Commentsに配置されているような複数行のテキストエディター。

Textport

テキストポート

Syntax Highlighting

構文の違いがわかるようにテキストカラーを有効にします。

Parenthesis and Quote Matching

カーソルを移動した時に一致する括弧や引用符をハイライトします。これは、括弧や引用符が適切に書かれているのか、また複雑なエクスプレッションの前と後が合っているのかわかります。

Context Sensitive Popup Help

有効なファンクション名またはオペレータパスをタイプしている時に、候補となる名前を表示します。ファンクションのパラメータに関しても用意されています。

Desktops and Toolbars

Save Desktops Automatically

デスクトップ内のペインに変更があれば、自動的に保存されます。

Show Hidden Files

非表示としてマークしたファイルを表示します(ファイル名がピリオドで始まる)。

Show All Files

ファイルのタイプに関係なく、すべてのファイルを表示します。

Path Menu Behavior

常にプロンプト(デフォルトの挙動)されるのではなく、Desktop Managerウィンドウを開いて、デスクトップの位置を切り替えるドロップダウンメニューを使う時のパスメニューの挙動を定義します。

Save Options

Save Method
Overwrite File

hipファイルの現在の状態で開いた既存ファイルを上書きします。

Increment Filename

有効にすると、番号を含んだファイルの名前で、その番号がファイルを保存する度に上がります。これはSave Asではなく、Saveのみで機能します(Scriptingの章でmwriteコマンドの-iオプションも参照してください)。

Make Numbered Backup

この設定をすると、.hipファイルのファイル名は変わりませんが、バックアップファイルが番号を上げて作成されます。デフォルトのバックアップディレクトリは./backup で、バックアップファイルの名前の後に_bak{num}が付きます。

Save View Commands For

このプリファレンスはファイルの肥大化を減らすのに役に立ちます。

All Viewers

すべての既存ビューアのビューコマンド(現在の開閉の状態)、まだ作成していないビューの隠れビューコマンドを保存します。

Existing Viewers

すべての既存ビューアのビューコマンド(現在の開閉の状態)を保存し、まだ作成していないビューの隠れビューコマンドを保存しません。

Open Viewers

現在開いているビューアのビューコマンドのみを保存します。

Auto Save Every Minutes

自動保存機能の間隔を指定します。

Auto Save Method
Overwrite File

hipファイルの現在の状態で開いた既存ファイルを上書きします。

Increment Filename

有効にすると、番号を含んだファイルの名前で、その番号がファイルを保存する度に上がります。

Make Numbered Backup

この設定をすると、.hipファイルのファイル名は変わりませんが、バックアップファイルが番号を上げて作成されます。デフォルトのバックアップディレクトリは./backupで、バックアップファイルの名前の後にauto{num}が付きます。

注目

EditメニューのAuto Saveチェックボックスをオンにして自動保存を有効にする必要があります。 Auto SaveはHoudiniを起動すると、自動的に無効になります。その理由は、Houdiniが遅くなり、意図しないでその設定のままになっているとディスクスペースを多く占有してしまうからです。セッション毎に手動で有効にしなければなりません。

Miscellaneous

Restrict Web Browser to Safe Commands

Houdiniの組み込みウェブブラウザから実行可能なHScriptコマンドを制限します。 このオプションをオンにすれば、悪意のあるプログラムがHoudiniを通じてコマンドが実行されることを防止できます。

Use External Help Server

Houdiniの組み込みブラウザではなく、システムのデフォルトのウェブブラウザでHoudiniヘルプドキュメントが開きます。

Reserve Kb for the Undo System

HoudiniのUndoシステムで使用するメモリ量を指定します。割り当てるメモリ量が多いほど、Houdiniがより多くのUndoができます。

Delete Channels When Reverting to Defaults

Revert to Defaultsオペレーションを実行すると、変更したパラメータのチャンネルが削除されます。

Revert Invisible Parameters to Defaults

不可視パラメータがRevert to Defaultsオペレーションによって影響を受けるか否か指定します。

Make Spare Parameters for Unknown Channels

このオプションをオンにすると、あなたのHoudiniのバージョンに存在しない特別なパラメータの値を保持するためにスペアパラメータが作成されるので、ビットバケット(データを破棄する仮想上の場所)にその特別なパラメータを破棄せずに、何が変わったのか確認でき、その値を復旧することができます。これは、古いバージョンのhipファイルや古いノードを含んだOTLを読み込む時に役に立ちます。しかし、廃止されたパラメータで混乱したくないのであれば、このオプションをオフにします。

Spare/HDA Parameter Deletion

When you are in a Type Propertiesでパラメータの1つを削除する時、アセット内のパラメータがそのパラメータを指している場合があります。

デフォルトは、Automatically Delete all Referencesです。Automatically Delete only Simple Channel Referencesは、参照をいくつか残す保守的な仕事をして、複雑なエクスプレッションをあまり破壊しません。Do Not Automatically Delete any Referencesは、ぶらさがっている参照をそのままにしますが、エクスプレッションが影響を受ける可能性を除去します。

Hip File Options

Unit Length

Houdiniの1単位の長さをメートルで指定します。この値は、単位固有のDOPパラメータで使われます。

Unit Mass

Houdiniの1単位の重さをキログラムで指定します。この値は、単位固有のDOPパラメータで使われます。

注目

Houdiniの1単位の時間は常に1秒です。

Warning Dialogs

このウィンドウ内のオプションは警告のオン・オフを切り替えることができます。デフォルトでは、すべての警告ダイアログがオンになっています。

Performance Options

Percentage Thresholds

ここでは、パフォーマンスモニターを使用するときにノードの相対的な処理時間を表示するのに使用するカラー値を設定します。

ランプの使い方の詳細は、ランプパラメータを参照してください。

このページ上

関連トピック